Support‎ > ‎

mInvoice Support

The help below will give you a working knowledge of the mInvoice App.  This should allow you to navigate the program interface and perform many of the program features. 

Additional online help can be found below:


Application Overview

Main Navigation
Main Navigation
Navigating mInvoice is pretty straightforward. On the left side of the screen you’ll find icons that represent the major functions of the program.  These are:
  • Dashboard
  • Customers
  • Products
  • Quotes
  • Invoices
Clicking on one of these icons will bring up records for that function.

The function that is currently displayed is shown in the green shaded color.  You can see from the image to the left that the Invoice Screen is currently active.





 
Action Bar


Action Bar

The action bar is shown along the top status bar of the program.

There are a few ways to add new records into the program. The simplest is to click on the "Add" icon for the function in the Action Bar.   A new window will be displayed and you can enter your data.   

You can also access preferences from the Action Bar and toggle the Action Panel described below.

You can search records by typing in your search criteria and pressing enter.



 
Action Panel

Action Panel
The Action panel is a window that can be toggled on and off and is shown pinned to the right side of the screen.

Depending on which function is being displayed, the buttons and options available on the action panel vary.  The action panel shown to the left is for the Invoice screen.  

Most of the actions on the panel are also available via right clicking on the data list.  












 
Main Screen - Dashboard

Main Screen - Invoices


Main Screen
The images to the left show the main screens for both the Dashboard and Invoice functions.

You can see the Main Navigation bar on the left side of the screen and the Action Bar at the top.   On the Invoices screen, you can also see that the Action Panel is open and shown to the right of the invoice list.  
























 
Popup Menus


Popup Menus
mInvoice makes use of context sensitive popup menus that are available by right clicking on rows in the data tables. If you right-click on a record in the Invoice Table, you would be shown the menu to the left. Each of the main functions (Customer, Products, Quotes and Invoices) have their own menus and the options and settings that appear are unique to that function.

Each of the main functions allows you to filter the records displayed. Filtering works by right clicking and selecting one of the filtering options. The records displayed will be updated to match your filter. Note that the filters are compoundable. In other words, if you filter on a particular item and then filter on a different item, you get the records that match both items. You can clear the filter by using the Clear Filter Menu Option.

Running reports and exporting data use the current search and/or filter.







 
Customers
Customer Records
To the left is the main Customer screen. This screen is used to add and edit customer records.    

There are several tabs at the top of the screen that provide access do different information.

Details - The main tab that shows the details about the record.  

Invoices & Payments - shows you all invoices and payments that the customer has made.

Comments - Free form comments that you can enter for the record.






 
Products

Product Records
The Products screen allows you to add or edit a product record.  The fields are relatively straight forward.   

There are several tabs at the top of the screen that provide access do different information.


Details - The main tab that shows the details about the record.  

Comments - Free form comments that you can enter for the record.






 
Quotes
Quote Records
The Quotes screen allows you to add or edit a quote record.  

There are several tabs at the top of the screen that provide access do different information.


Details - The main tab that shows the details about the record.  Complete the main fields on the form and then click the "add..." button to add products to your quote. You can also drag and drop them from the main Products List.  Once a product is added, you can edit the fields that are shown in red to the left.  To edit a record, click on the product and press tab or enter.  Enter the new value and then tab to the next editable field.  You can also double click on the field you want to edit.

Comments - Free form comments that you can enter for the record.

NOTE - once a quote is move to "Invoiced" status you are unable to make changes to the information on the form unless you move it back to "Drafted Status".  This is to make sure that accidental edits are not made.



 
Invoices


Invoice Records
The Invoices screen allows you to add or edit a invoice record.  This is similar to the quotes screen, but has additional data required for the invoice.

There are several tabs at the top of the screen that provide access do different information.


Details - The main tab that shows the details about the record.  Complete the main fields on the form and then click the "add..." button to add products to your quote. You can also drag and drop them from the main Products List.  Once a product is added, you can edit the fields that are shown in red to the left.  To edit a record, click on the product and press tab or enter.  Enter the new value and then tab to the next editable field.  You can also double click on the field you want to edit.

Shipping Terms and Payments - This tab allows you to update data related to the shipping and payment of the products/invoice.

Comments - Free form comments that you can enter for the record.

NOTE - once an invoice is move to "Recorded" or "Completed" status you are unable to make changes to the information on the form unless you move it back to "Drafted Status".  This is to make sure that accidental edits are not made.



General Preferences
Preferences & Setup - Company
The preferences screen allows you to control application settings.

On the 'Company" tab, you can enter data related to your business.  This information is used on reports throughout the program to customize them with your data.

Complete the company fields at the top of the screen.

To upload a Logo or Signature, locate the file on your computer and drag the image from the finder window to the logo box on the preferences screen.  Note that a Logo or Signature can not be larger than 400 wide x 128 high.

The bottom of the screen allows you to create comments related to your company as well as specific invoice or quote comments that you want to have displayed at the bottom of each invoice or quote report.







Table Column Preferences


Preferences & Setup  - Settings
The preferences screen allows you to control application settings.

On the 'Settings" tab, you can set options on how the program operations.  These are pretty straightforward.


















 
Advanced Preferences
Preferences & Setup - Currencies
The preferences screen allows you to control application settings.

On the 'currencies" tab, you can select specific currencies that your business operations in.  Once these are added to this screen, they will be available to all quotes and invoices that you create.  You can also specify the currency of each product that you add.

You should also select a "Primary" currency.  This is the currency that all totals including the data in the dashboard are shown.  mInvoice automatically converts the currency on the quote or invoice to the "Primary" currency.

Currency rates are updated automatically each day.









 
Advanced Preferences
Preferences & Setup - Advanced
The preferences screen allows you to control application settings.

On the 'advanced" tab, you can setup advanced program settings as well as compact your mInvoice database file.

mInvoice can be setup to automatically make backup copies of your database/company files.  Select the automatic backup option and specify how many backups that you would like retained.

Custom Numbering can be used to control the format and sequence number for invoice and quote numbers.











 
New Database



New Company
While most customer won't need this, mInventory supports the creation of multiple company databases.   You can create a new company via the menu option: File -> New Company...

You will be shown the screen to the left and can give it a name.  The company database will be created and automatically opened.   mInventory only support a single database being open at a given time.




 
Open Database
Open Company
To open a company database, you select the menu option:  File -> Open Company...

You will see the screen to the left.  Click on the company you wish to open and press the open button.

- - - - - - -   Additional Database Options - - - - - - - 

MANAGE DATABASES:  Selecting File -> Manage Databases... opens a file manager window that allows you to see the actual database files that you have created in mInvoice.   You can copy or delete these directly.   Please be careful when using this screen as you can easily remove a database by mistake.    NOTE - mInvoice can only interact with database files that are in this location.   If you copy a file out of this location, it will not be accessible by the program.   This is due to sandbox limitations placed on app developers.

BACKUP DATABASES:  Selection File -> Backup Now will automatically backup the current opened database.    You should get into the habit of doing this every so often.  
MANAGE BACKUPS:  Selection File -> Manage Backups... opens a file manager window that allows you to see the database files that have been backed up.  If you have done this occasionally, you will see multiple instances of each of your database files.  They are identified by database name and date/time stamp of the backup.

The listing of database backups can be useful if for some reason your main database is corrupt or you make some mistakes in the program and want to back out some of your changes.   We recommend that you backup before performing large imports or doing a considerable number of changes.  You should backup again after this work is complete.  

If for some reason you need to recover a backup file you simply copy the file from the MANAGE BACKUPS location to the MANAGE DATABASE location.   You should rename the file once it is copied over.  Note that is doesn't need to be the same name as your original.  If the database file is in the MANAGE DATABASE finder folder, mInvoice will be able to see it and you can open it.